Security Update

Security Update

You may have heard that BACS will be making changes to their security procedures with effect from 13th June 2016.  These changes are necessary because the internet community is adopting more stringent security measures (including SHA-2), which will affect the requirements for accessing secure services, like BACS.

You can rest assured that London & Zurich will have the necessary protocols (SHA-2 SSL certificates and TLS 1.1/1.2) in place well ahead of this date. At the same time, London & Zurich will be withdrawing support for older connection methods to provide even more protection for our management suite and integrated users.

From 13th June 2016 we will only support TLS 1.2. To ensure you can continue to access our services, you should check that you are using a compatible web browser.

For details of our supported web browsers, please see below:

Browsers
Internet Explorer (From Version 11)
Google Chrome (From Version 26)
Firefox (From Version 27)
Safari (From Version 7)

In addition, it is recommended that you use the most up-to-date version of your browser. The following links will guide you through the process of updating to the latest version of your browser:

Internet Explorer
Google Chrome
Mozilla Firefox
Safari

If you have an integration with the London & Zurich direct debit management suite, you will need to check that you are able to connect and communicate with our services using TLS 1.2.

If you have any questions for us in relation to these changes, please do not hesitate to contact us.